Tulip Actively investigating APP Impact - Degradation - July 18th 2025

Incident Report for Tulip

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 18:17 UTC

Monitoring

We believe that there has been a temporary issue due to an external outage from our cloud provider.
We are actively monitoring the situation and will share any further updates.
Posted Jul 18, 2025 - 16:07 UTC

Investigating

We are currently investigating possible degradation in Google Cloud.
We have identified that Tulip applications and integration have been impacted.
Our team is actively monitoring and investigating the situation.
Posted Jul 18, 2025 - 15:46 UTC
This incident affected: Tulip North America (Clienteling - Communication, Clienteling - Customer Management, Appointments, Catalog, Point of Sale, Platform, Integrations, Analytics, Admin Console).