We are continuing to monitor for any further issues.
Posted Jul 29, 2025 - 14:51 UTC
Monitoring
A fix has been implemented to mitigate the problem, and the Customer Capture form is now operational again. The team will continue to monitor the situation.
If you are experiencing issues with a blank customer capture form, please close and relaunch the application. This action will help clear the cache and restore proper functionality.
Posted Jul 29, 2025 - 14:45 UTC
Identified
The team has identified the root cause of the problem and are working to resolve this issue.
Posted Jul 29, 2025 - 14:17 UTC
Update
Teams continue to investigate and work towards resolving
Posted Jul 29, 2025 - 13:59 UTC
Investigating
Hello Customer,
We are currently experiencing issues with customer capture, which may result in a blank page when loading. Our teams are actively investigating and working to resolve this as quickly as possible.
Thank you,
Posted Jul 29, 2025 - 13:43 UTC
This incident affected: Tulip North America (Clienteling - Customer Management), Tulip Deutschland (Clienteling - Customer Management), and Tulip European Union (Clienteling - Customer Management).